Commandes CISCO

Introduction

qsd

 

Commande de base

Switch(config)# hostname SWITCH
SWITCH(config)#
Ro(config)# interface FastEthernet 0/1
Ro(config-if)# no shutdown
Ro(config-if)# ip address 192.168.1.1 255.255.255.0

Switching

Sw(config)# vlan 10
Sw(config-vlan)# name SERVER
Sw(config-vlan)# exit
Sw(config)# interface FastEthernet 0/1
Sw(config-if)# switchport access vlan 10 
Sw(config-if)# switchport mode access 
Sw(config)# interface FastEthernet 0/1
Sw(config-if)# switchport mode trunk
Sw(config-if)# switchport trunk encapsulation dot1q

Routing

Ro(config)# ip route 192.168.1.0 0.0.0.255 1.1.1.2 name VERS_WAN

Services

SNMP v1

Router(config)# access-list 2 permit 192.168.0.1
Router(config)# snmp-server community Finger RO 2
Router(config)# snmp-server host 192.168.0.1 Finger

SNMP v2c

Router(config)# access-list 2 permit 192.168.0.1
Router(config)# snmp-server community Finger RO 2
Router(config)# snmp-server host 192.168.0.1 version 2c Finger

SNMP v3

Router(config)# snmp-server group Finger v3 auth write v1default
Router(config)# snmp-server user EyesOfNetwork Finger v3 auth md5 P@ssw0rd
Router(config)# snmp-server host 192.168.0.1 version 3 auth EyesOfNetwork

NAT Statique

interface fa 0/1 
 description LAN
 ip address 192.168.1.254 255.255.255.0
 ip nat inside
!
interface fa 0/2
 description WAN 
 ip address 200.1.1.254 255.255.255.0
 ip nat outside
!
ip nat inside source static 192.168.1.1 200.1.1.1
ip nat inside source static 192.168.1.2 200.1.1.2
ip nat inside source static 192.168.1.3 200.1.1.3
etc ...

NAT dynamique

interface fa 0/1 
 description LAN
 ip address 192.168.1.254 255.255.255.0
 ip nat inside
!
interface fa 0/2
 description WAN 
 ip address 200.1.1.254 255.255.255.0
 ip nat outside
!
ip nat pool MAISON 200.1.1.1 200.1.1.3 netmask 255.255.255.0
ip nat inside source list 10 pool MAISON
!
access-list 10 permit 192.168.1.1
access-list 10 permit 192.168.1.2
etc ...

PAT (NAT overlay)

interface FastEthernet0/1 
 description LAN
 ip address 192.168.1.254 255.255.255.0
 ip nat inside
!
interface FastEthernet0/2
 description WAN 
 ip address 200.1.1.254 255.255.255.0
 ip nat outside
!
ip nat inside source list 10 interface FastEthernet0/2 overload
!
access-list 10 permit 192.168.1.0 0.0.0.255
etc ...
ip dhcp excluded-address 192.168.1.254              
ip dhcp excluded-address 192.168.1.1 192.168.1.2    

ip dhcp pool FINGER_POOL                            
 network 192.168.1.0 255.255.255.0                
 default-router 192.168.1.254                       
 dns-server 192.168.1.1 192.168.1.2
 lease 0 0 10

ip dhcp pool FINGER_POOL_FIXE_90
 network 192.168.1.90 255.255.255.0
 hardware-address 000b.6b52.3268
 default-router 192.168.1.254
 dns-server 192.168.1.1 192.168.1.2
 lease 0 0 10

Merci de votre soutien et de votre fidélité ! Ce site existe grâce à vous et je ne vous remercierais jamais assez !

PARTIE 5 – SECURITY

Cette ou ces vidéos d’E-Learning sont réservées aux membres du site FingerInTheNet « GOLD » et « PREMIUM« .
La création et la conception de ces supports de cours ont pris énormément de temps et d’argent à nos équipes.
Merci de votre compréhension.

Installez-vous dans votre canapé, préparer vos pop-corn, votre bloc-notes et feu patate 🙂

 

Les ACLs (Access Control Lists)



PARTIE 5 - SECURITY 1

/// ABONNE-TOI ///

Configurer des options de sécurité de niveau 2



Le DHCP snooping et le DAI (dynamic ARP inspection)


PARTIE 5 - SECURITY 1

/// ABONNE-TOI ///

Le port security


PARTIE 5 - SECURITY 1

/// ABONNE-TOI ///

Le modèle AAA



PARTIE 5 - SECURITY 1

/// ABONNE-TOI ///

 

 

En espérant que vous avez apprécié ces vidéos !

N’hésitez pas à me le faire savoir !!

FingerInTheNet

PARTIE 4 – SERVICES

Cette ou ces vidéos d’E-Learning sont réservées aux membres du site FingerInTheNet « GOLD » et « PREMIUM« .
La création et la conception de ces supports de cours ont pris énormément de temps et d’argent à nos équipes.
Merci de votre compréhension.

Installez-vous dans votre canapé, préparer vos pop-corn, votre bloc-notes et feu patate 🙂

 

01 / Le protocole NAT



Théorie



PARTIE 4 - SERVICES 5

/// ABONNE-TOI ///

Configuration



PARTIE 4 - SERVICES 5

/// ABONNE-TOI ///

02 / Le protocole SNMP



PARTIE 4 - SERVICES 5

/// ABONNE-TOI ///

03 / Le protocole DHCP



PARTIE 4 - SERVICES 5

/// ABONNE-TOI ///

04 / Le protocole SSH



PARTIE 4 - SERVICES 5

/// ABONNE-TOI ///

En espérant que vous avez apprécié ces vidéos !

N’hésitez pas à me le faire savoir !!

FingerInTheNet

PARTIE 3 – ROUTING

Cette ou ces vidéos d’E-Learning sont réservées aux membres du site FingerInTheNet « GOLD » et « PREMIUM« .
La création et la conception de ces supports de cours ont pris énormément de temps et d’argent à nos équipes.
Merci de votre compréhension.

Installez-vous dans votre canapé, préparer vos pop-corn, votre bloc-notes et feu patate 🙂

 

01 – THÉORIE – FONCTIONNEMENT D’UN ROUTEUR



 

02 – THÉORIE – LES TABLES DE ROUTAGE



 

03 – THÉORIE – ROUTAGE DYNAMIQUE



PARTIE 3 - ROUTING 10

/// ABONNE-TOI ///

 

04 – CONFIG – ROUTAGE STATIQUE



PARTIE 3 - ROUTING 11

/// ABONNE-TOI ///

05 – THÉORIE – ROUTAGE INTER-VLAN



PARTIE 3 - ROUTING 12

/// ABONNE-TOI ///

06 – CONFIG – ROUTAGE INTER-VLAN – ROAS



PARTIE 3 - ROUTING 13

/// ABONNE-TOI ///

07 – CONFIG – ROUTAGE INTER-VLAN – SVI



PARTIE 3 - ROUTING 14

/// ABONNE-TOI ///

08 – THÉORIE – LE PROTOCOLE OSPF



PARTIE 3 - ROUTING 15

/// ABONNE-TOI ///

09 – CONFIG – LE PROTOCOLE OSPF



PARTIE 3 - ROUTING 15

/// ABONNE-TOI ///

 

 

00 – INTRODUCTION

Ces vidéos expliquent les bases du réseau.
L’équipe FingerInTheNet vous offre gratuitement ce support de cours afin de vous aider dans vos premiers pas dans le monde des réseaux !
N’hésitez pas à nous dire merci en commentaire pour nous remercier 😉

 

01 – Switch – Routeur | À quoi ça sert ?



 

02 – Présentation physique des équipements



 

03 – Les mémoires CISCO



 

04 – Connexion en mode console



 

05 – Débuter avec Packet Tracer



 

En espérant que vous avez apprécié ces vidéos !

N’hésitez pas à me le faire savoir !!

FingerInTheNet

PARTIE 2 – SWITCHING

Cette ou ces vidéos d’E-Learning sont réservées aux membres du site FingerInTheNet « GOLD » et « PREMIUM« .
La création et la conception de ces supports de cours ont pris énormément de temps et d’argent à nos équipes.
Merci de votre compréhension.

Installez-vous dans votre canapé, préparer vos pop-corn, votre bloc-notes et feu patate 🙂

 

01 – THÉORIE – Vlan



 

02 – CONFIG – Vlan



PARTIE 2 - SWITCHING 17

/// ABONNE-TOI ///

03 – THÉORIE – Trunk



PARTIE 2 - SWITCHING 18

/// ABONNE-TOI ///

04 – CONFIG – Trunk



PARTIE 2 - SWITCHING 19

/// ABONNE-TOI ///

05 – THÉORIE – Introduction au Spanning Tree



 

06 – THÉORIE – Protocole STP (1/2)



 

PARTIE 2 - SWITCHING 20

/// ABONNE-TOI ///

07 – THÉORIE – Protocole STP (2/2)



 

PARTIE 2 - SWITCHING 21

/// ABONNE-TOI ///

08 – THÉORIE – Protocole RSTP



 

PARTIE 2 - SWITCHING 22

/// ABONNE-TOI ///

09 – CONFIG – Spanning-Tree



 

PARTIE 2 - SWITCHING 23

/// ABONNE-TOI ///

10 – Etherchannel



 

PARTIE 2 - SWITCHING 24

/// ABONNE-TOI ///

11 – CDP / LLDP



 

PARTIE 2 - SWITCHING 25

/// ABONNE-TOI ///

12 – THÉORIE – FHRP



 

PARTIE 2 - SWITCHING 25

/// ABONNE-TOI ///

En espérant que vous avez apprécié ces vidéos !

N’hésitez pas à me le faire savoir !!

FingerInTheNet

01 – LES BASES

Ces vidéos expliquent les bases du réseau.
L’équipe FingerInTheNet vous offre gratuitement ce support de cours afin de vous aider dans vos premiers pas dans le monde des réseaux !
N’hésitez pas à nous dire merci en commentaire pour nous remercier 😉

 

01 – THÉORIE -Le code binaire



 

02 – PRATIQUE – Le code binaire



01 - LES BASES 27

 

03 – THÉORIE – Le modèle OSI



01 - LES BASES 27

 

04 – THÉORIE – Le modèle TCP/IP



01 - LES BASES 27

 

05 – THÉORIE – Le câblage



 

06 – THÉORIE – Les adresses MAC



 

 

07 – THÉORIE – La table CAM



 

08 – THÉORIE – Les adresses IP



 

09 – THÉORIE – Les adresses IPv4



 

10 – THÉORIE – Evolution IPv4



 

11 – THÉORIE – Le subnetting



 

En espérant que vous avez apprécié ces vidéos !

N’hésitez pas à me le faire savoir !!

FingerInTheNet

Vidéo – Trunk

Cette ou ces vidéos d’E-Learning sont réservées aux membres du site FingerInTheNet « GOLD » et « PREMIUM« .
La création et la conception de ces supports de cours ont pris énormément de temps et d’argent à nos équipes.
Merci de votre compréhension.

Installez-vous dans votre canapé, préparer vos pop-corn, votre bloc-notes et feu patate 🙂

 

Théorie Trunk



/// ABONNE-TOI ///

 

Configuration Trunk



/// ABONNE-TOI ///

 

En espérant que vous avez apprécié ces vidéos !

N’hésitez pas à me le faire savoir !!

FingerInTheNet

Vidéo – Vlan

Cette ou ces vidéos d’E-Learning sont réservées aux membres du site FingerInTheNet « GOLD » et « PREMIUM« .
La création et la conception de ces supports de cours ont pris énormément de temps et d’argent à nos équipes.
Merci de votre compréhension.

Installez-vous dans votre canapé, préparer vos pop-corn, votre bloc-notes et feu patate 🙂

 

Théorie Vlan



/// ABONNE-TOI ///

 

Configuration Vlan



/// ABONNE-TOI ///

 

En espérant que vous avez apprécié ces vidéos !

N’hésitez pas à me le faire savoir !!

FingerInTheNet

Travaux pratique – VOIP

CHAPITRE 1 :

L'architecture

Travaux pratique - VOIP 30
CHAPITRE 2 :

La consigne

Créer cette architecture sous packet tracer. Les équipements réseau à utiliser sont les suivants :

  • 3 x Routeur CISCO 2811
  • 2 x Switch CISCO 2950
  • 4 x IP Phone 7960
CHAPITRE 3 :

La configuration

Configuration de SW_1

### CONFIGURATION DES VLANS ### 

SW_1(config)# vlan 10
SW_1(config-vlan)# name DATA
SW_1(config-vlan)# exit
SW_1(config)# vlan 110
SW_1(config-vlan)# name VOICE
SW_1(config-vlan)# exit

### CONFIGURATION DES PORTS CLIENTS ###
 
SW_1(config)# interface range FastEthernet 0/1-2
SW_1(config-if-range)# switchport mode access
SW_1(config-if-range)# switchport access vlan 10
SW_1(config-if-range)# switchport voice vlan 110

### CONFIGURATION DU PORT TRUNK ### 

SW_1(config)# interface FastEthernet 0/24
SW_1(config-if)# description VERS_R1
SW_1(config-if)# switchport mode trunk

Configuration de SW_2

### CONFIGURATION DES VLANS ### 

SW_2(config)# vlan 20
SW_2(config-vlan)# name DATA
SW_2(config-vlan)# exit
SW_2(config)# vlan 120
SW_2(config-vlan)# name VOICE
SW_2(config-vlan)# exit

### CONFIGURATION DES PORTS CLIENTS ###
 
SW_2(config)# interface range FastEthernet 0/1-2
SW_2(config-if-range)# switchport mode access
SW_2(config-if-range)# switchport access vlan 20
SW_2(config-if-range)# switchport voice vlan 120

### CONFIGURATION DU PORT TRUNK ###
 
SW_2(config)# interface FastEthernet 0/24
SW_2(config-if)# description VERS_R1
SW_2(config-if)# switchport mode trunk

Configuration de R1

### CONFIGURATION DES INTERFACES PHYSIQUE ###

R1(config)# interface FastEthernet 0/1
R1(config-if)# description VERS_WAN
R1(config-if)# ip address 10.0.12.1 255.255.255.0
R1(config-if)# no shutdown

R1(config)# interface FastEthernet 0/0
R1(config-if)# description VERS_LAN
R1(config-if)# no shutdown

### CONFIGURATION DES INTERFACES VIRTUELLE ###

R1(config)# interface FastEthernet 0/0.10
R1(config-subif)# description DATA
R1(config-subif)# ip address 192.168.10.254 255.255.255.0
R1(config-subif)# encapsulation dot1q 10

R1(config)# interface FastEthernet 0/0.110
R1(config-subif)# description VOICE
R1(config-subif)# ip address 192.168.110.254 255.255.255.0
R1(config-subif)# encapsulation dot1q 110

### CONFIGURATION DES SERVEURS DHCP ###

R1(config)# ip dhcp pool DATA
R1(dhcp-config)# network 192.168.10.0 255.255.255.0
R1(dhcp-config)# default-router 192.168.10.254

R1(config)# ip dhcp pool VOICE
R1(dhcp-config)# network 192.168.110.0 255.255.255.0
R1(dhcp-config)# default-router 192.168.110.254
R1(dhcp-config)# option 150 ip 192.168.110.254
R1(dhcp-config)# exit

option 150 : permet de spécifier l'adresse du serveur TFTP à partir duquel le 
téléphone IP unifié Cisco télécharge le fichier de configuration d'image.

R1(config)# ip route 0.0.0.0 0.0.0.0 10.0.12.2 name VERS_R2

Configuration de R2

### CONFIGURATION DES INTERFACES PHYSIQUE ###

R2(config)# interface FastEthernet 0/0
R2(config-if)# description VERS_R1
R2(config-if)# ip address 10.0.12.2 255.255.255.0
R2(config-if)# no shutdown

R2(config)# interface FastEthernet 0/1
R2(config-if)# description VERS_R3
R2(config-if)# ip address 10.0.23.2 255.255.255.0 
R2(config-if)# no shutdown

### CONFIGURATION DU ROUTAGE STATIQUE ### 

R2(config)# ip route 192.168.10.0 255.255.255.0 10.0.12.1 name VERS_R1
R2(config)# ip route 192.168.110.0 255.255.255.0 10.0.12.1 name VERS_R1
R2(config)# ip route 192.168.20.0 255.255.255.0 10.0.23.3 name VERS_R3
R2(config)# ip route 192.168.120.0 255.255.255.0 10.0.23.3 name VERS_R3

Configuration de R3

### CONFIGURATION DES INTERFACES PHYSIQUE ###

R3(config)# interface FastEthernet 0/1
R3(config-if)# description VERS_WAN
R3(config-if)# ip address 10.0.23.3 255.255.255.0
R3(config-if)# no shutdown

R3(config)# interface FastEthernet 0/0
R3(config-if)# description VERS_LAN
R3(config-if)# no shutdown

### CONFIGURATION DES INTERFACES VIRTUELLE ###

R3(config)# interface FastEthernet 0/0.20
R3(config-subif)# description DATA
R3(config-subif)# ip address 192.168.20.254 255.255.255.0
R3(config-subif)# encapsulation dot1q 20

R3(config)# interface FastEthernet 0/0.120
R3(config-subif)# description VOICE
R3(config-subif)# ip address 192.168.120.254 255.255.255.0
R3(config-subif)# encapsulation dot1q 120

### CONFIGURATION DES SERVEURS DHCP ###

R3(config)# ip dhcp pool DATA
R3(dhcp-config)# network 192.168.20.0 255.255.255.0
R3(dhcp-config)# default-router 192.168.20.254

R3(config)# ip dhcp pool VOICE
R3(dhcp-config)# network 192.168.120.0 255.255.255.0
R3(dhcp-config)# default-router 192.168.120.254
R3(dhcp-config)# option 150 ip 192.168.120.254
R3(dhcp-config)# exit

option 150 : permet de spécifier l'adresse du serveur TFTP à partir duquel le 
téléphone IP unifié Cisco télécharge le fichier de configuration d'image.

R3(config)# ip route 0.0.0.0 0.0.0.0 10.0.23.2 name VERS_R2
CHAPITRE 4 :

La configuration de la partie VOIP

Configuration de R1

### CONFIGURATION DU CALL MANAGER ###

telephony-service 
 tftp-server flash:XXXXXXXXX (Inutile sous packet tracer)
 max-ephones 3
 max-dn 3
 ip source-address 192.168.110.254 port 2000

### CONFIGURER LES ABONNÉES ###

ephone-dn 1
 number 1001 
 name Noël NICOLAS

ephone-dn 2 
 number 1002 
 name Jérémy DUBOIS

### CONFIGURATION DES TÉLÉPHONES ###

ephone 1
 mac-address XXXX.XXXX.XXXX
 type 7960
 button 1:1

ephone 2
 mac-address XXXX.XXXX.XXXX
 type 7960
 button 1:2
La commande button button-number (separator) dn-tag afin d’associer le numéro du bouton et les caractéristiques de la ligne à une extension. Dans ce cas, utilisez un séparateur : (deux-points) qui implique une sonnerie normale.

Configuration de R3

### CONFIGURATION DU CALL MANAGER ###

telephony-service 
 tftp-server flash:XXXXXXXXX (Inutile sous packet tracer)
 max-ephones 3
 max-dn 3
 ip source-address 192.168.120.254 port 2000

### CONFIGURER LES ABONNÉES ###

ephone-dn 1
 number 2001 
 name Teddy PERRAUD

ephone-dn 2 
 number 2002 
 name Stéphane PIC

### CONFIGURATION DES TÉLÉPHONES ###

ephone 1
 mac-address XXXX.XXXX.XXXX
 type 7960
 button 1:1

ephone 2
 mac-address XXXX.XXXX.XXXX
 type 7960
 button 1:2

Source : https://www.cisco.com/c/fr_ca/support/docs/voice-unified-communications/unity-express/62609-tdcmecue.html

Merci de votre soutien et de votre fidélité ! Ce site existe grâce à vous et je ne vous remercierais jamais assez !