Finger in the net
Blog d'administration réseau
Generic selectors
Exact matches only
Search in title
Search in content
Post Type Selectors
Created by potrace 1.10, written by Peter Selinger 2001-2011

Configuration simplifié d’OSPF

Finger In The Net

Présentation du protocole OSPF en vidéo

configuration du protocole OSPF

Étape 1 : Activation du protocole OSPF

R1(config)# router ospf X

X = Numéro de processus OSPF. Ce numéro n’a aucune importance, mettez ce que vous voulez.

Le protocole OSPF est activé ! Mais il est complètement aveugle pour le moment. Il ne sait pas :

  • Quel réseau activer
  • À quel routeur diffuser les informations qu’il connaît
Le routeur OSPF ne connaît personne pour le moment
Le routeur OSPF ne connaît personne pour le moment

Étape 2 : Donner une identité à notre routeur OSPF

Notre routeur va bientôt échanger avec d’autres routeurs OSPF. Avant toute chose, il est primordial de lui donner un nom, une identité. Cette identité va s’appeler le Router-ID

R1(config)# router ospf 1
R1(config-router)# router-id 10.10.10.1

Étape 3 : Déclarer des réseaux dans OSPF

Notre routeur a 4 réseaux qui lui sont directement connectés :

  • 192.168.1.0 /24
  • 2.2.2.0 /24
  • 3.3.3.0 /24
  • 4.4.4.0 /24

Du coup on va le dire à notre protocole OSPF :

R1(config)# router ospf 1
R1(config-router)# network 192.168.1.0 0.0.0.255 area 0
R1(config-router)# network 2.2.2.0 0.0.0.255 area 0
R1(config-router)# network 3.3.3.0 0.0.0.255 area 0
R1(config-router)# network 4.4.4.0 0.0.0.255 area 0

La commande network permet de :

  • Déclarer ce réseau aux autres routeurs OSPF.
  • Chercher d’autre routeur OSPF dans ce réseau.

0.0.0.255 c’est quoi ?

  • Afin de déclarer un réseau, le protocole OSPF s’attend à recevoir un masque de type Wildcard-mask (masque inversé).

area 0 c’est quoi ?

  • Le protocole OSPF travaille en groupe de travail appelé area. Notre routeur est donc dans l’aire 0.
  • L’aire 0 est l’aire principale pour OSPF. Donc mettez tout le temps vos routeurs dans l’aire 0 quand vous commencez à créer une bulle OSPF. (Pour plus de détail, allez voir l’article dédié aux aires OSPF).
Le routeur R1 à trouvé les routeurs R2, R3 et R4 via la commande network
Le routeur R1 à trouvé les routeurs R2, R3 et R4 via la commande network

R1 a découvert des routeurs OSPF sur les réseaux :

  • 2.2.2.0 /24
  • 3.3.3.0 /24
  • 4.4.4.0 /24

Il va donc pouvoir envoyer et recevoir des informations de routages avec eux.

Sur le réseau 192.168.1.0 /24, le routeur R1 n’a trouvé personne. Ce qui est normal vu que c’est un réseau client.
Nous allons donc dire à R1 de ne pas chercher de routeurs sur ce réseau.

R1(config)# router ospf 1
R1(config-if)# passive-interface FastEthernet 0/0

Étape 4 : Les aires OSPF

R1(config)# router ospf [XXX]
R1(config-router)# network [network] [wildcard-mask] area [area-number]

Soit :

R1(config)# router ospf 10
R1(config-router)# network 10.10.10.0 0.0.0.255 area 0

[XXX] = 10
[network] = 10.10.10.0
[wildcard-mask] = 0.0.0.255
[area-number] = 0

On fait le point :

R1(config)# router ospf 1
R1(config-router)# router-id 10.10.10.1
R1(config-router)# network 192.168.1.0 0.0.0.255 area 0
R1(config-router)# network 2.2.2.0 0.0.0.255 area 0
R1(config-router)# network 3.3.3.0 0.0.0.255 area 0
R1(config-router)# network 4.4.4.0 0.0.0.255 area 0
R1(config-router)# passive-interface FastEthernet 0/0

Noël NICOLAS

Expert Réseau
11 ans d’expérience
CCNP Routing and Switching
Fondateur du site FingerInTheNet

Laisser un commentaire

Votre adresse e-mail ne sera pas publiée.

trois + 9 =

CURSUS DE FORMATION

LA BOUTIQUE
DES GEEKS