Generic selectors
Exact matches only
Search in title
Search in content
Post Type Selectors

Travaux pratique – VOIP

Article de blog | Finger In The Net

CHAPITRE 1 :

L'architecture

CHAPITRE 2 :

La consigne

Créer cette architecture sous packet tracer. Les équipements réseau à utiliser sont les suivants :

  • 3 x Routeur CISCO 2811
  • 2 x Switch CISCO 2950
  • 4 x IP Phone 7960
CHAPITRE 3 :

La configuration

Configuration de SW_1

### CONFIGURATION DES VLANS ### 

SW_1(config)# vlan 10
SW_1(config-vlan)# name DATA
SW_1(config-vlan)# exit
SW_1(config)# vlan 110
SW_1(config-vlan)# name VOICE
SW_1(config-vlan)# exit

### CONFIGURATION DES PORTS CLIENTS ###
 
SW_1(config)# interface range FastEthernet 0/1-2
SW_1(config-if-range)# switchport mode access
SW_1(config-if-range)# switchport access vlan 10
SW_1(config-if-range)# switchport voice vlan 110

### CONFIGURATION DU PORT TRUNK ### 

SW_1(config)# interface FastEthernet 0/24
SW_1(config-if)# description VERS_R1
SW_1(config-if)# switchport mode trunk

Configuration de SW_2

### CONFIGURATION DES VLANS ### 

SW_2(config)# vlan 20
SW_2(config-vlan)# name DATA
SW_2(config-vlan)# exit
SW_2(config)# vlan 120
SW_2(config-vlan)# name VOICE
SW_2(config-vlan)# exit

### CONFIGURATION DES PORTS CLIENTS ###
 
SW_2(config)# interface range FastEthernet 0/1-2
SW_2(config-if-range)# switchport mode access
SW_2(config-if-range)# switchport access vlan 20
SW_2(config-if-range)# switchport voice vlan 120

### CONFIGURATION DU PORT TRUNK ###
 
SW_2(config)# interface FastEthernet 0/24
SW_2(config-if)# description VERS_R1
SW_2(config-if)# switchport mode trunk

Configuration de R1

### CONFIGURATION DES INTERFACES PHYSIQUE ###

R1(config)# interface FastEthernet 0/1
R1(config-if)# description VERS_WAN
R1(config-if)# ip address 10.0.12.1 255.255.255.0
R1(config-if)# no shutdown

R1(config)# interface FastEthernet 0/0
R1(config-if)# description VERS_LAN
R1(config-if)# no shutdown

### CONFIGURATION DES INTERFACES VIRTUELLE ###

R1(config)# interface FastEthernet 0/0.10
R1(config-subif)# description DATA
R1(config-subif)# ip address 192.168.10.254 255.255.255.0
R1(config-subif)# encapsulation dot1q 10

R1(config)# interface FastEthernet 0/0.110
R1(config-subif)# description VOICE
R1(config-subif)# ip address 192.168.110.254 255.255.255.0
R1(config-subif)# encapsulation dot1q 110

### CONFIGURATION DES SERVEURS DHCP ###

R1(config)# ip dhcp pool DATA
R1(dhcp-config)# network 192.168.10.0 255.255.255.0
R1(dhcp-config)# default-router 192.168.10.254

R1(config)# ip dhcp pool VOICE
R1(dhcp-config)# network 192.168.110.0 255.255.255.0
R1(dhcp-config)# default-router 192.168.110.254
R1(dhcp-config)# option 150 ip 192.168.110.254
R1(dhcp-config)# exit

option 150 : permet de spécifier l'adresse du serveur TFTP à partir duquel le 
téléphone IP unifié Cisco télécharge le fichier de configuration d'image.

R1(config)# ip route 0.0.0.0 0.0.0.0 10.0.12.2 name VERS_R2

Configuration de R2

### CONFIGURATION DES INTERFACES PHYSIQUE ###

R2(config)# interface FastEthernet 0/0
R2(config-if)# description VERS_R1
R2(config-if)# ip address 10.0.12.2 255.255.255.0
R2(config-if)# no shutdown

R2(config)# interface FastEthernet 0/1
R2(config-if)# description VERS_R3
R2(config-if)# ip address 10.0.23.2 255.255.255.0 
R2(config-if)# no shutdown

### CONFIGURATION DU ROUTAGE STATIQUE ### 

R2(config)# ip route 192.168.10.0 255.255.255.0 10.0.12.1 name VERS_R1
R2(config)# ip route 192.168.110.0 255.255.255.0 10.0.12.1 name VERS_R1
R2(config)# ip route 192.168.20.0 255.255.255.0 10.0.23.3 name VERS_R3
R2(config)# ip route 192.168.120.0 255.255.255.0 10.0.23.3 name VERS_R3

Configuration de R3

### CONFIGURATION DES INTERFACES PHYSIQUE ###

R3(config)# interface FastEthernet 0/1
R3(config-if)# description VERS_WAN
R3(config-if)# ip address 10.0.23.3 255.255.255.0
R3(config-if)# no shutdown

R3(config)# interface FastEthernet 0/0
R3(config-if)# description VERS_LAN
R3(config-if)# no shutdown

### CONFIGURATION DES INTERFACES VIRTUELLE ###

R3(config)# interface FastEthernet 0/0.20
R3(config-subif)# description DATA
R3(config-subif)# ip address 192.168.20.254 255.255.255.0
R3(config-subif)# encapsulation dot1q 20

R3(config)# interface FastEthernet 0/0.120
R3(config-subif)# description VOICE
R3(config-subif)# ip address 192.168.120.254 255.255.255.0
R3(config-subif)# encapsulation dot1q 120

### CONFIGURATION DES SERVEURS DHCP ###

R3(config)# ip dhcp pool DATA
R3(dhcp-config)# network 192.168.20.0 255.255.255.0
R3(dhcp-config)# default-router 192.168.20.254

R3(config)# ip dhcp pool VOICE
R3(dhcp-config)# network 192.168.120.0 255.255.255.0
R3(dhcp-config)# default-router 192.168.120.254
R3(dhcp-config)# option 150 ip 192.168.120.254
R3(dhcp-config)# exit

option 150 : permet de spécifier l'adresse du serveur TFTP à partir duquel le 
téléphone IP unifié Cisco télécharge le fichier de configuration d'image.

R3(config)# ip route 0.0.0.0 0.0.0.0 10.0.23.2 name VERS_R2
CHAPITRE 4 :

La configuration de la partie VOIP

Configuration de R1

### CONFIGURATION DU CALL MANAGER ###

telephony-service 
 tftp-server flash:XXXXXXXXX (Inutile sous packet tracer)
 max-ephones 3
 max-dn 3
 ip source-address 192.168.110.254 port 2000

### CONFIGURER LES ABONNÉES ###

ephone-dn 1
 number 1001 
 name Noël NICOLAS

ephone-dn 2 
 number 1002 
 name Jérémy DUBOIS

### CONFIGURATION DES TÉLÉPHONES ###

ephone 1
 mac-address XXXX.XXXX.XXXX
 type 7960
 button 1:1

ephone 2
 mac-address XXXX.XXXX.XXXX
 type 7960
 button 1:2
La commande button button-number (separator) dn-tag afin d’associer le numéro du bouton et les caractéristiques de la ligne à une extension. Dans ce cas, utilisez un séparateur : (deux-points) qui implique une sonnerie normale.

Configuration de R3

### CONFIGURATION DU CALL MANAGER ###

telephony-service 
 tftp-server flash:XXXXXXXXX (Inutile sous packet tracer)
 max-ephones 3
 max-dn 3
 ip source-address 192.168.120.254 port 2000

### CONFIGURER LES ABONNÉES ###

ephone-dn 1
 number 2001 
 name Teddy PERRAUD

ephone-dn 2 
 number 2002 
 name Stéphane PIC

### CONFIGURATION DES TÉLÉPHONES ###

ephone 1
 mac-address XXXX.XXXX.XXXX
 type 7960
 button 1:1

ephone 2
 mac-address XXXX.XXXX.XXXX
 type 7960
 button 1:2

Source : https://www.cisco.com/c/fr_ca/support/docs/voice-unified-communications/unity-express/62609-tdcmecue.html

Merci de votre soutien et de votre fidélité ! Ce site existe grâce à vous et je ne vous remercierais jamais assez !

Noël NICOLAS

Co-auteur de l'article

Expert Réseau
15 ans d’expérience
CCNP Routing and Switching
Fondateur du site FingerInTheNet

Eric JOUFFRILLON

Co-auteur de l'article

Expert SATCOM
Technicien Réseau
17 ans d’éxpérience déploiement réseau SATCOM
Spécialisé LFN (Long Fat Network).Diffusion vidéo et QOS.

CURSUS DE FORMATION

Administrateur Réseau