Les Tunnels GRE

R1(config)# interface FastEthernet 0/1
R1(config-if)# description VERS_LAN
R1(config-if)# ip address 192.168.10.254 255.255.255.0
R1(config-if)# exit

R1(config)# interface FastEthernet 0/2
R1(config-if)# description VERS_R2
R1(config-if)# ip address 192.168.30.1 255.255.255.0
R1(config-if)# exit

R1(config)# interface tunnel 1
R1(config-if)# description TUNNEL
R1(config-if)# ip address 1.1.10.1 255.255.255.248
R1(config-if)# tunnel source 192.168.30.1
R1(config-if)# tunnel destination 192.168.40.1
R1(config-if)# exit

R1(config)# ip route 192.168.20.0 255.255.255.0 1.1.10.2
R1(config)# ip route 192.168.40.0 255.255.255.0 192.168.30.2
R2(config)# interface FastEthernet 0/1
R2(config-if)# description VERS_R1
R2(config-if)# ip address 192.168.10.254 255.255.255.0
R2(config-if)# exit

R2(config)# interface FastEthernet 0/2
R2(config-if)# description VERS_R3
R2(config-if)# ip address 192.168.30.1 255.255.255.0
R2(config-if)# exit

R3(config)# interface FastEthernet 0/1
R3(config-if)# description VERS_LAN
R3(config-if)# ip address 192.168.20.254 255.255.255.0
R3(config-if)# exit

R3(config)# interface FastEthernet 0/2
R3(config-if)# description VERS_R2
R3(config-if)# ip address 192.168.30.1 255.255.255.0
R3(config-if)# exit

R3(config)# interface tunnel 1
R3(config-if)# description TUNNEL
R3(config-if)# ip address 1.1.10.2 255.255.255.248
R3(config-if)# tunnel source 192.168.40.1
R3(config-if)# tunnel destination 192.168.30.1
R3(config-if)# exit

R3(config)# ip route 192.168.10.0 255.255.255.0 1.1.10.1
R3(config)# ip route 192.168.30.0 255.255.255.0 192.168.40.2