Generic selectors
Exact matches only
Search in title
Search in content
Post Type Selectors
Created by potrace 1.10, written by Peter Selinger 2001-2011

Virtual Switching System (VSS)

Finger In The Net

Le VSS (Virtual Switching System) est un protocole CISCO, il est remplacé par le Stackwise Virtuel (même principe de fonctionnement – dans les certifications CISCO, on parle uniquement de VSS). Ce protocole est uniquement disponible sur les séries Catalyst 6500 et 4500 exécutant un IOS-XE.

Le protocole VSS est un protocole CISCO qui permet de fusionner deux Switchs CISCO.

VSS CISCO
Avantage du VSS
Chapitre 1

Le protocole VSS

Avantages du VSS

Avantage du VSS:

  • Simple à mettre en place.
  • Taux de convergence entre 100 et 200 ms en cas de panne.
  • Plus besoin des protocoles FHRP comme le HSRP le VRRP et le GLBP.
  • Une seule adresse IP de passerelle par VLAN au lieu de 3 (1 IP Active + 1 IP Passive + 1 IP Virtuel).
  • Tous nos liens sont activés !!! (À l’inverse du Spanning Tree).

Principe de fonctionnement

VSS cisco

2 Catalyst 6500 utilisant le VSS

Afin de faire fusionner nos deux Switchs, nous allons devoir :

  • Créer un domaine VSS.
  • Créer une liaison entre eux (Lien VSL).
  • Appliquer la configuration pour que nos deux Switch reboot et fusionnent.
  • Choisir un modèle de redondance.

/!\ Attention /!\  Ne pas confondre le VSS et le StackWise !!!

  • Une liaison VSS se fait via des interfaces physiques “Normal” (Ethernet / Fibre)
  • Une liaison StackWise se fait en fond de panier avec des ports et des câbles spécifiques !!!!

Un Switch va devenir “Active” et l’autre va devenir “Standby“. Cela permet de définir qui va être le chef d’orchestre.

  • Nos deux équipements fonctionnent simultanément.
  • Les tables ARP et MAC sont synchronisés entre nos deux équipements.
Chapitre 2

Configuration du VSS

Étape 1 : Le domaine VSS

Switch-01(config)# switch virtual domain 1
Switch-01(config-vs-domain)# switch 1
Switch-01(config-vs-domain)# switch 1 priority 110
Switch-01(config-vs-domain)# switch 2 priority 100
Switch-02(config)# switch virtual domain 1
Switch-02(config-vs-domain)# switch 2
Switch-02(config-vs-domain)# switch 1 priority 110
Switch-02(config-vs-domain)# switch 2 priority 100

Etape 2 : Créer le lien VSL

Switch-01(config)# interface port-channel 1
Switch-01(config-if)# switch virtual link 1
Switch-01(config-if)# no shutdown
Switch-01(config-if)# exit
Switch-01(config)# interface range TenGigaBitEthernet 1/1 - 2
Switch-01(config-if-range)# channel-group 1 mode on
Switch-01(config-if-range)# no shut
Switch-02(config)# interface port-channel 1
Switch-02(config-if)# switch virtual link 1
Switch-02(config-if)# no shutdown
Switch-02(config-if)# exit
Switch-02(config)# interface range TenGigaBitEthernet 1/1 - 2
Switch-02(config-if-range)# channel-group 1 mode on
Switch-02(config-if-range)# no shutdown

Étape 3 : Appliquer le VSS

Switch-01# switch convert mode virtual
Do you want to proceed? [yes/no]: yes
Switch-02# switch convert mode virtual
Do you want to proceed? [yes/no]: yes
Chapitre 3

Mode de redondance

Présentation

Il existe 3 modes de redondances VSS :
  • RPR = Route Processor Redundancy
  • RPR+ = Route Processor Redundancy +
  • SSO = Stateful SwitchOver
Le mode RPR met 2 minutes à basculer. Le mode RPR+ met 30 secondes à basculer. Le mode SSO met moins de 1 seconde à basculer.
Switch(config)# redundancy
Switch(config-red)# mode [ rpr | rpr-plus | sso ]

Synchronisation

Switch(config)# redundancy
Switch(config-red)# main-cpu
Switch(config-r-mc)# auto-sync [ startup-config | config-register | bootvar ]
Chapitre 4

Nonstop Forwarding (NSF)

Présentation du NSF

Le NSF (NonStop Forwarding) fonctionne uniquement avec le mode SSO.

Il permet de converger instantanément d’un switch à l’autre en matière de routage en cas de panne !

Imaginez que vous êtes en conversation Skype et que le Switch (appartenant au VSS) par lequel vos paquets transitent tombe en panne.

Grâce au NSF, cette panne va devenir transparente à vos yeux !!

Configuration du NSF avec BGP

Switch(config)# router bgp as-number
Switch(config-router)# bgp graceful-restart

Configuration du NSF avec OSPF

Switch(config)# router eigrp as-number
Switch(config-router)# nsf

Configuration du NSF avec EIGRP

Switch(config)# router ospf process-id
Switch(config-router)# nsf

Sur le même thème :

Noël NICOLAS

Expert Réseau
11 ans d’expérience
CCNP Routing and Switching
Fondateur du site FingerInTheNet

Comments (4)

Bonjour Monsieur NICOLAS,
Je vous remercie beaucoup pour votre exellent site qui m’aide pour préparer mon examen CCNP Routing and Switching.
Merci une autre fois.

Très cordialement,
Jamal

Félicitations !

Quelques questions :

1 – Finalement, VSS ne configure pas (physiquement et logiquement) de la même façon que le StackWise ?

2 – Je n’ai donc pas besoin de pratiquer le VSS pour préparer le CCNP ?

Bonjour Nocolas,

Merci de me precise , ACtuellement en 2022 , quel type de catlyst permet de faire le VSS car le switch de 4500 et 6500 ne sont pas à vendre actuellement. donc preciser quel type de switch permet de faire ces choses de vss or vcs ?

Laisser un commentaire

Votre adresse e-mail ne sera pas publiée. Les champs obligatoires sont indiqués avec *

18 − 15 =

Guide de préparation officiel au

CCNA 200-301

CURSUS DE FORMATION