Finger in the net
Blog d'administration réseau
Generic selectors
Exact matches only
Search in title
Search in content
Post Type Selectors
Created by potrace 1.10, written by Peter Selinger 2001-2011

EtherChannel

Finger In The Net

L’EtherChannel permet de regrouper (agréger) plusieurs ports pour n’en faire qu’un seul.

L’expression “Agrégat de lien” revient souvent dans le jargon technique français (Agrégation = Regrouper des éléments). J’utiliserais la terminologie “EtherChannel” car toutes les documentations CISCO sont en anglais et il est important de se familiariser avec les terminologies anglaises.

Sachant qu’un bon croquis vaut mieux qu’un long discours, rentrons directement dans le sujet :

Nous avons une liaison entre deux switchs à 100Mb/s. Notre switch n’à que des ports en Fast Ethernet (100 Mbps).

Etherchannel - Principe de base 01
Etherchannel – Principe de base 01

Nous avons besoin d’une liaison à 400Mb/s. Nous avons qu’à ajouter trois liens entre ces switchs !

Etherchannel - Principe de base 02
Etherchannel – Principe de base 02

Malheureusement mes liens ne veulent pas monter … Pourquoi ? Car nos équipements considèrent cela comme une boucle réseau ! Le protocole STP garde uniquement une interface fonctionnelle. Comment faire ?

Mettre en place de l’EtherChannel 🙂

Etherchannel - Principe de base 03
Etherchannel – Principe de base 03

L’EtherChannel permet de regrouper des interfaces physiques dans un groupe. Ce groupe sera vu comme une interface virtuel par notre switch.
Pour faire simple , nous avons 8 Ports (4 à droite et 4 à gauche) il faut qu’il soit :

  • Tous identique (Ethernet ou Fast Ethernet ou GigaBitEthernet etc …)
  • De nombre égal des deux côtés de notre Etherchannel.
  • Les ports que l’ont veut agréger d’un même switch soit dans le même “Channel-group

Si un des liens vient à tomber, l’EtherChannel continu sur 3 liaisons !

L’EtherChannel est limité à 8 interfaces

Cette liaison peut être mise en place de deux façons :

  • En mode “Manuel” (via le mode “on”)
  • En mode “Automatique” (via les protocoles PAgP et LACP)

Il existe deux protocoles Etherchannel :

PAgP (Port Aggregation Protocol)

  • Propriétaire CISCO
  • Deux modes : (Auto / Desirable)

LACP (Link Aggregation Control Protocol)

  • Norme IEEE 802.3ad
  • Deux modes : (Active/Passive)
Switch(config-if)# channel-group 1 mode ?

active         Enable LACP unconditionally
auto           Enable PAgP only if a PAgP device is detected
desirable      Enable PAgP unconditionally
on             Enable Etherchannel only
passive        Enable LACP only if a LACP device is detected

Le protocole par défaut est le protocole PagP. Pour utiliser le protocole LACP , il faut juste le dire à notre équipement avec la commande channel-protocol lacp

Chapitre 1

Configuration de Etherchannel

La configuration suivante permet de configurer automatiquement une liaison Etherchannel

Etherchannel de niveau 2

Switch(config)# interface range FastEthernet 0/1 -4
Switch(config-range)# channel-group 1 mode on
Switch(config-range)# exit

Switch(config)# interface port-channel 1
Switch(config-if)# description VERS_SWITCH_B
Switch(config-if)# switchport mode trunk
Switch(config-if)# switchport trunk encapsulation dot1q

Etherchannel de niveau 3

Switch(config)# interface range FastEthernet 0/1 -4
Switch(config-range)# no ip address
Switch(config-range)# channel-group 1 mode on
Switch(config-range)# exit

Switch(config)# interface port-channel 1
Switch(config-if)# description VERS_SWITCH_B 
Switch(config-if)# ip address X.X.X.X X.X.X.X
Chapitre 2

Configuration de PAGP (CISCO)

La configuration suivante permet de forcer l’utilisation du protocole PAGP

PaGP de niveau 2

Switch(config)# interface range FastEthernet 0/1 -4
Switch(config-range)# channel-protocol pagp 
Switch(config-range)# channel-group 1 mode [ Desirable | Auto ] Switch(config-range)# exit Switch(config)# interface port-channel 1 Switch(config-if)# description VERS_SWITCH_B Switch(config-if)# switchport mode trunk Switch(config-if)# switchport trunk encapsulation dot1q

PAGP de niveau 3

Switch(config)# interface range FastEthernet 0/1 -4
Switch(config-range)# no ip address
Switch(config-range)# channel-protocol pagp 
Switch(config-range)# channel-group 1 mode [ Desirable | Auto ] Switch(config-range)# exit Switch(config)# interface port-channel 1 Switch(config-if)# description VERS_SWITCH_B Switch(config-if)# ip address X.X.X.X X.X.X.X
Chapitre 3

Configuration de LACP (IEEE)

La configuration suivante permet de forcer l’utilisation du protocole LACP

LACP de niveau 2

Switch(config)# interface range FastEthernet 0/1 -4
Switch(config-range)# channel-protocol lacp 
Switch(config-range)# channel-group 1 mode [ Active | Passive ] Switch(config-range)# exit
Switch(config)# interface port-channel 1 Switch(config-if)# description VERS_SWITCH_B Switch(config-if)# switchport mode trunk Switch(config-if)# switchport trunk encapsulation dot1q

LACP de niveau 3

Switch(config)# interface range FastEthernet 0/1 -4
Switch(config-range)# no ip address
Switch(config-range)# channel-protocol lacp 
Switch(config-range)# channel-group 1 mode [ Active | Passive ] Switch(config-range)# exit Switch(config)# interface port-channel 1 Switch(config-if)# description VERS_SWITCH_B Switch(config-if)# ip address X.X.X.X X.X.X.X
Chapitre 4

LOAD BALANCING

Afin de faire de l’équilibrage de charge sur les interfaces physiques participant à l’EtherChannel, nos Switchs peuvent répartir les trames à envoyer en fonction de plusieurs paramètres :

  • src-mac — Adresse MAC source  — Bits
  • dst-mac — Adresse MAC destination Bits
  • src-dst-mac — Adresse MAC source et destination XOR
  • src-ip —Adresse IP source Bits
  • dst-ip — Adresse IP destination Bits
  • src-dst-ip —Adresse IP source et destination (Default) XOR
  • src-port —Port source Bits
  • dst-port — Port destination Bits
  • src-dst-port —Port source et destination XOR

Configuration

La méthode d’équilibrage de charge ce modifie de la façon suivante :

Switch(config)# port-channel load-balance src-dst-ip

Vérifier la partie load-balancing de votre liaison :

Vérification

Switch# show etherchannel load-balance

EtherChannel Load-Balancing Configuration: src-dst-mac EtherChannel Load-Balancing Addresses Used Per-Protocol: Non-IP: Source XOR Destination MAC address IPv4: Source XOR Destination MAC address IPv6: Source XOR Destination MAC address

 

Chapitre 5

Pour finir

Mind-Map Etherchannel

Sur le même thème :

Noël NICOLAS

Expert Réseau
11 ans d’expérience
CCNP Routing and Switching
Fondateur du site FingerInTheNet

Comments (4)

Excellent ! Félicitations.

Je ne comprends pas le rôle des différentes options de load-balancing. Ça serait utile d’expliquer l’exemple : “port-channel load-balance src-dst-ip”.

Laisser un commentaire

Votre adresse e-mail ne sera pas publiée.

quinze + 10 =

CURSUS DE FORMATION

LA BOUTIQUE
DES GEEKS