Generic selectors
Exact matches only
Search in title
Search in content
Post Type Selectors
Created by potrace 1.10, written by Peter Selinger 2001-2011

Le protocole EIGRP

Finger In The Net

EIGRP = Enhanced Interior Gateway Routing Protocol

  • propriétaire CISCO
  • protocole de routage dynamique
  • protocole IGP
  • protocole Classless
  • utilise le Distance Vector
  • envoi des “Updates Messages” à ses neighbor’s afin de les informer de la topologie existante
  • envoi ses “Updates Messages” en Multicast sur l’adresse 224.0.0.10.
  • les “Updates Messages” n’utilisent ni le TCP, ni l’UDP mais le RTP (Reliable Transport Protocol)

Avantage de l’EIGRP :

  • prend en compte le Bandwith ET le Delay
  • vitesse de convergence instantanée (il a un coup d’avance par rapport à OSPF car il sait déjà par où passer en cas de panne)
  • on n’a pas une vision globale du réseau, mais il fait confiance à ses voisins, ce qui lui permet de ne pas perdre de temps pour trouve un meilleur chemin

Pour fonctionner, le protocole EIGRP utilise trois tables :

  • Neighbor table (table de voisinage) = Cette table va lister tous les voisins que connait notre routeur.
  • Topology table (table topologique) = Cette table va contenir tous les réseaux appris par ses voisins.
  • Routing table (table de routage) = Toutes les routes possédant le Metric le plus faible présent dans la “Topology table” vont être mise dans notre table de routage.
Chapitre 1

La table de voisinage

Le but de cette table est de tenir une liste à jour de nos interlocuteurs EIGRP.
Pour ce faire, plusieurs étapes :

  • Router-ID : se trouver un identifiant unique
  • Neighbor : partir à la recherche de ses voisins potentiels
  • Neighbor table : mettre ses informations dans une table de voisinage

Voyons ces trois étapes en détail…

Le router-ID

Router-ID = Adresse IP de notre Routeur EIGRP.

Le Router-ID est défini comme suit :

  • Priorité 1 : le Router ID renseigné manuellement.
  • Priorité 2 : L’adresse IP la plus élevée configurée sur une interface loopback.
  • Priorité 3 : L’adresse IP la plus élevée configurée sur une interface physique.

Cette adresse IP permet de pouvoir être identifié par les routeurs EIGRP voisins.

Les neighbors

Un neighbor (voisin) est une relation entre deux routeurs EIGRP. Ils vont tous les deux s’envoyer des paquets « Hello » (« Bonjour ») afin de se présenter.

Les conditions pour devenir neighbor (voisin) sont les suivantes :

  • EIGRP – Authentification identique.
  • EIGRP – Valeur K identique (le recommandation Cisco est de ne pas changer cette valeur!).
  • EIGRP – Numéro d’AS identique ( router eigrp X ).
  • EIGRP – Appartenir à un même réseau.
  • EIGRP – Router-ID unique (non obligatoire, mais fortement conseillé).
EIGRP - Neighbor
EIGRP – Neighbor

Dans ce cas, nos deux routeurs se considèrent comme “Neighbors”.

La NEIGHBORS TABLE

Une fois que nous avons trouvé un voisin valide, notre routeur va compléter sa neighbor table. Pour l’afficher, utilisez la commande suivante

R1# show ip eigrp neighbors
IP-EIGRP neighbors for process 1
H   Address   Interface   Hold  Uptime      SRTT   RTO     Q      Seq
                                 (sec)      (ms)          Cnt     Num
0   2.2.2.2     Fa0/0      10   2:56:19      40    1000    27       1
1
2
...
  • H  (Handle) = Classement par ordre d’arrivée de nos voisins (0 , 1 , 2 , 3 , ect.)
  • Address = Router-ID de notre voisin
  • Interface = Interface d’interconnexion avec notre voisin
  • Hold Time = Temps d’attente maximum pour recevoir un paquet Hello de notre voisin, 15 secondes par défaut
  • Uptime =  Depuis quand notre voisin est UP
  • SRTT (Smooth Round Trip Time) = Temps de retransmission
  • RTO (Retransmission TimeOut) =  Temps de retransmission maximum avant d’être Time off
  • Q Cnt (Queue Count) = Nombre de paquets en attente d’être retransmis (Update, Reply, Query). Si ce nombre est supérieur à 0, présence de congestions réseau.
  • Seq Number (Sequence Number)  =  Le dernier numéro de séquence de paquet reçu par notre voisin
Chapitre 2

La Topology Table

Une fois que deux routeurs sont officiellement des neighbors, ils vont s’échanger tout ce qu’ils savent en matière de routage.

Chaque routeur va envoyer :

  • les réseaux qu’il sait joindre
  • la distance entre lui et ce réseau

Pour ce faire, il y a deux termes à retenir :

  • Reported Distance (RD) = La distance qui sépare notre voisin à un réseau
  • Feasible Distance (FD) = La distance qui me sépare de ce réseau.
Le protocole EIGRP 1
FD
 

Étape 1 : R2 est directement connecté au réseau 1.1.1.0 /24.
Étape 2 : R2 calcule le Metric entre ce réseau et lui-même et en conclue son FD.
Étape 3 : R2 envoie son FD à R1.
Étape 4 : R1 reçoit le FD de R2 et le nomme RD.
Étape 5 : R1 calcule le Metric entre R1 et R2, fait l’addition entre le RD et le Metric et en conclue son FD.

Dans l’exemple ci-dessous, nous pouvons voir que R1 possède 3 neighbors (R11, R12, et R13) :

  • Ces 3 routeurs sont capables de joindre le réseau LAN-21.
  • Ces 3 routeurs vont donc l’annoncer à R1.

R1 va donc mettre dans sa Topology Table ces informations.

La question est : Quel chemin va prendre R1 pour joindre le LAN-21 ?

Reported Distance (RD) / Advertised Distance (AD)

Reported Distance (RD) / Advertised Distance (AD) = Metric calculé par un voisin. Les Termes RD ou AD veulent dirent la même chose !!!
  • dans le CCNA, on parle de RD
  • dans le CCNP, on parle de AD
⇒ Le RD ou AD est tout simplement le FD de nos voisins !!!
EIGRP - Topology Table
EIGRP – Topology Table

Calcul du Metric

R11 = 10 + 10 = 20 R12 = 20 + 10 = 30 R13 = 10 + 10 = 20

R11
  • possède un Metric de 20 pour joindre LAN-21
  • possède un FD de 20 pour le LAN-21
  • envoie son FD pour ce réseau à R1
R12
  • possède un Metric de 30 pour joindre LAN-21
  • possède un FD de 30 pour le LAN-21
  • envoie son FD pour ce réseau à R1
R13
  • possède un metric de 20 pour joindre LAN-21
  • possède un FD de 20 pour le LAN-21
  • envoi son FD pour ce réseau à R1
R1
  • met le RD de R11 dans sa table topologique
  • met le RD de R12 dans sa table topologique
  • met le RD de R13 dans sa table topologique

Feasible Distance (FD)

Le Routeur R1 va donc calculer le Metric de chaque route possible et choisir le Metric le plus faible comme référence. Cette référence est appelée Feasible Distance (FD)
EIGRP - Topology Table
EIGRP – Topology Table

Calcul du Metric

Via R11 = 10 + 20 = 30 Via R12 = 10 + 30 = 40 Via R13 = 30 + 20 = 50

Successor

Le tronçon avec la bande passante la plus faible qui sépare notre routeur du réseau à atteindre va être pris en compte.
EIGRP - Feasible Successor
EIGRP – Feasible Successor
  • Si le RD appris par un voisin est plus faible que mon FD, c’est que le routeur est plus “proche” que moi de mon destinataire, il est donc un successeur potentiel (Feasible successor).
  • Si le RD appris par un voisin est plus grand ou égal à mon FD, il va ignorer ce routeur pour ce réseau.
Via R12
  • FD = RD (30 = 30)
  • R1 ignore ce réseau
Via R13
  • FD > RD ( 30 > 20 )
  • R1 choisit le passé par R13
Question : Mais !!!! Pourquoi on ne passe pas par R12 ?
  • FD via R12 < FD via R13
  • Le Metric est plus faible via R12 !
Réponse : EIGRP fonctionne comme ça…

Feasible Successor

Le tronçon avec la bande passante la plus faible qui sépare notre routeur du réseau à atteindre va être pris en compte.
EIGRP - Feasible Successor
EIGRP – Feasible Successor
  • Si le RD appris par un voisin est plus faible que mon FD, c’est que le routeur est plus “proche” que moi de mon destinataire, il est donc un successeur potentiel (Feasible successor).
  • Si le RD appris par un voisin est plus grand ou égal à mon FD, il va ignorer ce routeur pour ce réseau.
Via R12
  • FD = RD (30 = 30)
  • R1 ignore ce réseau
Via R13
  • FD > RD ( 30 > 20 )
  • R1 choisit le passé par R13
Question : Mais !!!! Pourquoi on ne passe pas par R12 ?
  • FD via R12 < FD via R13
  • Le Metric est plus faible via R12 !
Réponse : EIGRP fonctionne comme ça…
Chapitre 3

La table de routage

Le protocole EIGRP va uniquement mettre dans sa table de routage sur la meilleure route afin d’attendre un réseau.

R1# show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate
default U - per-user static route
Gateway of last resort is not set

D     LAN-21     [90/30] via 1.1.11.2, 00:01:39, FastEthernet0/11

D = Route EIGRP
90 = Administrative Distance
30 = FD = Metric

Chapitre 4

Configuration du protocole EIGRP

Étape 1 : Activation du protocole EIGRP

R1(config)# router eigrp X

X = =Doit être identique!

Le protocole EIGRP est activé ! Mais il est complètement aveugle pour le moment. Il ne sait pas :

  • Quel réseau activer
  • À quel routeur diffuser les informations qu’il connaît
Le routeur OSPF ne connaît personne pour le moment
Le routeur OSPF ne connaît personne pour le moment

Étape 2 : Donner une identité à notre routeur EIGRP

Notre routeur va bientôt échanger avec d’autres routeurs EIGRP. Avant toute chose, il est primordial de lui donner un nom, une identité. Cette identité va s’appeler le Router-ID

R1(config)# router eigrp 1
R1(config-router)# eigrp router-id 10.10.10.1

Étape 3 : Déclarer des réseaux dans EIGRP

Notre routeur a 4 réseaux qui lui sont directement connectés :

  • 192.168.1.0 /24
  • 2.2.2.0 /24
  • 3.3.3.0 /24
  • 4.4.4.0 /24

Du coup on va le dire à notre protocole OSPF :

R1(config)# router eigrp 1
R1(config-router)# network 192.168.1.0 0.0.0.255
R1(config-router)# network 2.2.2.0 0.0.0.255
R1(config-router)# network 3.3.3.0 0.0.0.255
R1(config-router)# network 4.4.4.0 0.0.0.255

La commande network permet de :

  • Déclarer ce réseau aux autres routeurs EIGRP.
  • Chercher d’autre routeur EIGRP dans ce réseau.

0.0.0.255 c’est quoi ?

  • Afin de déclarer un réseau, le protocole EIGRP s’attend à recevoir un masque de type Wildcard-mask (masque inversé).

Étape 3 : Déclarer des réseaux dans EIGRP

Pour éviter de travailler en mode CLASSFULL (Classe A , B et C), activez l’auto-summary

R1(config)# router eigrp 1
R1(config-router)# no auto-summary

On fait le point :

R1(config)# router eigrp 1
R1(config-router)# eigrp router-id 10.10.10.1
R1(config-router)# network 192.168.1.0 0.0.0.255
R1(config-router)# network 2.2.2.0 0.0.0.255
R1(config-router)# network 3.3.3.0 0.0.0.255
R1(config-router)# network 4.4.4.0 0.0.0.255
R1(config-router)# passive-interface FastEthernet 0/0
R1(config-router)# no auto-summary
Merci de votre attention

Sur le même thème

Merci de votre soutien et de votre fidélité ! Ce site existe grâce à vous et je ne vous remercierais jamais assez !

Noël NICOLAS

Expert Réseau
11 ans d’expérience
CCNP Routing and Switching
Fondateur du site FingerInTheNet

Comments (12)

Merci pour ton retour !!
En espérant que tu as trouvé les réponses que tu cherchais.

Je suis en train de préparer mon CCNP ROUTE, du coup je vais mettre à jour cet article dans le mois !!

Au plaisir de te relire !!

Noël

Salut Niko !

La partie EIGRP as été complètement refait !!!

Tu trouveras beaucoup plus d’information sur le protocole EIGRP qu’il y as un mois !

Bonne lecture 😉

Bravo pour l’effort !

1 – “Cette adresse IP permet de pouvoir être identifié par les routeurs EIGRP voisins.” À ma connaissance, le router-id n’est généralement pas une adresse IP. C’est juste 4 bytes qui sont séparés par des points. 255.255.255.255 ou 0.0.0.0 sont des router-id valables ; alors qu’ils ne peuvent pas être des adresses IP. C’est le cas pour OSPF, c’est certain ! Pour les autres protocoles, je n’ai pas testé.

2 – L’article peut donner l’impression que la métrique totale EIGRP est calculée par simple cumul de métriques. Je crois que la formule est un peu plus complexe que ça : “metric = ([K1 * bandwidth + (K2 * bandwidth) / (256 – load) + K3 * delay] * [K5 / (reliability + K4)]) * 256, where bandwidth is the least bandwidth, delay is the sum of the delays”.

3 – Personnellement ; j’aurais suggéré de baser la présentation sur une vraie architecture (GNS3).

Bonjour KayouMT,

Je suis vraiment désolé, je n’ai pas trop eu le temps en ce moment pour répondre à tout tes commentaires, je commence à donner des cours début Aout et du coup je doit préparer mes cours sur la base des réseaux informatique.

Pour répondre à tes questions :

1/ Router-ID : Ok, je n’avais pas cette vision là du router ID, je vais essayer de fouiller un peu plus sur ce sujet.

2/ Le metric : Pour calculer le metric, il faut voir dans l’article “Metric”. La je suis partie du principe qu’on développera ce sujet plus tard pour ne pas partir dans tout les sens.

3/ Je viens de recevoir ma plateforme !!!!! Du coup je vais pouvoir retravaillé sur mes articles et apporté la partie “Pratique” que je n’avais pas.

Encore merci pour tes retour 🙂 J’essaye de te répondre au plus vite !

GREATNESS VOS EXPLICATIONS ET MERCI ….
je pensais que le FD consideré pour trouver le feasible successor est l unique FD passant par le successor lui meme qui sera comparé au RD….d ou incomprehension de ma svp…

Question : Mais !!!! Pourquoi on ne passe pas par R12 ?
– FD via R12 < FD via R13 ;
– Le Metric est plus faible via R12 !

R12 dit : J’ai un metric de 30 pour le LAN-21
R13 dit : J’ai un metric de 20 pour le LAN-21

R1 à un metric de 30 pour le LAN-21 via R11.

Il part du principe que R12 reporte un metric égale ou supérieur à ce qu’il à déjà. Il va donc l’ignorer.

C’est bête, mais c’est comme ça, ça fonctionne comme ça … Il faut le prendre en considération !

Bonjour,

Impossible d’accéder à la page EIGRP . Je suis abonnée, j’accède aux autres BGP, OSPF mais de que je reviens sur EIGRP je suis systematiquement déconnectée et quand je me reconnecte et que je retourne sur EIGRP je suis de nouveau deconnectée.

Merci

Laisser un commentaire

Votre adresse e-mail ne sera pas publiée. Les champs obligatoires sont indiqués avec *

2 + vingt =

Guide de préparation officiel au

CCNA 200-301

CURSUS DE FORMATION