Finger in the net
Blog d'administration réseau
Generic selectors
Exact matches only
Search in title
Search in content
Post Type Selectors
Created by potrace 1.10, written by Peter Selinger 2001-2011

Tunneling IPv6 over IPv4

Finger In The Net

 

INTRODUCTION


 

Ce cours a pour but de vous montrer comment faire passer de l’IPv6 au travers d’un monde IPv4 (IPv6 over IPv4).

 

 

 

Architecture de base



Architecture 6to4
Architecture 6to4

 

 

Configuration



 

 

Routeur R1


R1(config)# ipv6 unicast-routing

---- Configuration des protocoles de routages ----

R1(config)# ipv6 router eigrp 1 
R1(config-router)# eigrp router-id 1.1.1.1 
R1(config-router)# no shutdown 
R1(config-router)# exit 

R1(config)# router ospf 1 
R1(config-router)# network 10.10.10.0 0.0.0.255 area 0 
R1(config-router)# exit 

---- Configuration des interfaces physiques ---- 

R1(config)# interface FastEthernet 0/0 
R1(config-if)# description VERS_R2
R1(config-if)# ip address 10.10.10.1 255.255.255.0 
R1(config-if)# exit 

R1(config)# interface FastEthernet 0/1 
R1(config-if)# description VERS_LAN 
R1(config-if)# ipv6 address 2001:DB8:0:10::1/64 
R1(config-if)# ipv6 eigrp 1 
R1(config-if)# exit

---- Configuration du tunnel 6to4 ---- 

R1(config)# interface tunnel 10 
R1(config-if)# tunnel source FastEthernet 0/0 
R1(config-if)# tunnel destination 30.30.30.4 
R1(config-if)# tunnel mode ipv6ip 

Routeur R2


R2(config)# ipv6 unicast-routing 

---- Configuration des protocoles de routages ---- 

R2(config)# router ospf 1
R2(config-router)# network 10.10.10.0 0.0.0.255 area 0
R2(config-router)# network 20.20.20.0 0.0.0.255 area 0
R2(config-router)# exit

---- Configuration des interfaces physiques ---- 

R2(config)# interface FastEthernet 0/0
R2(config-if)# description VERS_R1
R2(config-if)# ip address 10.10.10.2 255.255.255.0
R2(config-if)# exit

R2(config)# interface FastEthernet 0/1
R2(config-if)# description VERS_R3
R2(config-if)# ip address 20.20.20.2 255.255.255.0
R2(config-if)# exit

 

Routeur R3


R3(config)# ipv6 unicast-routing 

---- Configuration des protocoles de routages ---- 

R3(config)# router ospf 1
R3(config-router)# network 20.20.20.0 0.0.0.255 area 0
R3(config-router)# network 30.30.30.0 0.0.0.255 area 0
R3(config-router)# exit

---- Configuration des interfaces physiques ---- 

R3(config)# interface FastEthernet 0/0
R3(config-if)# description VERS_R2
R3(config-if)# ip address 20.20.20.3 255.255.255.0
R3(config-if)# exit

R3(config)# interface FastEthernet 0/1
R3(config-if)# description VERS_R4
R3(config-if)# ip address 30.30.30.3 255.255.255.0
R3(config-if)# exit

 

Routeur R4


R4(config)# ipv6 unicast-routing

---- Configuration des protocoles de routages ---- 

R4(config)# ipv6 router eigrp 1
R4(config-router)# eigrp router-id 4.4.4.4
R4(config-router)# no shutdown
R4(config-router)# exit

R4(config)# router ospf 1 
R4(config-router)# network 10.10.10.0 0.0.0.255 area 0 
R4(config-router)# exit  

---- Configuration des interfaces physiques ---- 

R4(config)# interface FastEthernet 0/0
R4(config-if)# description VERS_R3
R4(config-if)# ip address 30.30.30.4 255.255.255.0
R4(config-if)# exit

R4(config)# interface FastEthernet 0/1
R4(config-if)# description VERS_LAN
R4(config-if)# ipv6 address 2001:DB8:0:20::1/64
R4(config-if)# ipv6 eigrp 1
R4(config-if)# exit

---- Configuration du tunnel 6to4 ---- 

R4(config)# interface tunnel 10
R4(config-if)# tunnel source Fastethernet 0/0
R4(config-if)# tunnel destination 10.10.10.1
R4(config-if)# tunnel mode ipv6ip

 

 

 

CONCLUSION


 

C’est super simple si vous êtes à l’aise avec les tunnels GRE.

 

 

En espérant que vous avez apprécié cet article !

N’hésitez pas à me la faire savoir !!

FingerInTheNet

Noël NICOLAS

Expert Réseau
11 ans d’expérience
CCNP Routing and Switching
Fondateur du site FingerInTheNet

Comments (3)

Félicitations pour les efforts et pour la capacité de vulgarisation.

J’aurais suggéré un certain nombre d’améliorations, pour grandement augmenter la qualité de l’article.

1 – Il serait pertinent d’écrire un article général (Introduction à l’interopérabilité entre IPv6 et IPv4). Dans cet article général, ce serait l’endroit pour définir des notions comme le Dual Stack. Ça serait aussi l’endroit pour comparer les différentes méthodes : ISTAP, TEREDO, NAT-PT, 6to4, IPv6-over-IPv4, …

2 – La configuration des routeurs R2 et R3 n’ont vraiment pas d’utilité dans cet article. Ça n’a pas de valeur ajoutée pour le sujet discuté. Tu peux carrément les enlever.

3 – Dans les routeurs R1 et R4, apparemment la configuration de FastEthernet 0/0 n’est pas correcte. Les adresses qu’on voit sur le schéma ne sont pas sont celles qui sont configurées.

4 – Dans les routeurs R1 et R4, apparemment le tunnel source n’est pas correct. Apparemment, c’est FastEthernet 0/0 qu’il fallait mettre à la place de FastEthernet 0/1.

5 – Ça serait utile de conclure l’article avec quelques commandes de test et de vérification.

There are some mistakes on this config :
* Ospf configutation is noy correct ( no auto-summary command under the ospf process)
* Router-id command on Eigrp is not correct ( the correct one is: eigrp router-id X.X.X.X )
* The interface tunnel 0 have to be configured for routing.

Please correct the config 🙂

KayouMT :

1 – Tu as raison !
2 – Je préfère laisser la configuration, ça mange pas de pain 🙂
3 – Done 🙂
4 – Done 🙂
5 – Il faut que je fasse un passage sur tout les articles pour rajouter cette partie.

Zak :

1 – Done 🙂
2 – Done 🙂
3 – What do you mean ?

Thank a lot for your comment 🙂

Laisser un commentaire

Votre adresse e-mail ne sera pas publiée.

5 × 3 =