Created by potrace 1.10, written by Peter Selinger 2001-2011
Finger in the net
Blog d'administration réseau
Created by potrace 1.10, written by Peter Selinger 2001-2011

Authentification OSPF

Finger In The Net
"3 Méthodes d’authentification possible pour l'authentification OSPF: - (0) Aucune : Par défaut - (1) Plain-text : Le mot de passe circule en clair. - (2) MD5 (Message-Digest 5) : Le mot de passe ne circule pas sur le réseau. ... [Lire la suite]"

 

INTRODUCTION


 
Il y a 3 méthodes d’authentification possible :

-> (0)Aucune :  Par défaut.
-> (1) Plain-text : Le mot de passe circule en clair.
-> (2) MD5 (Message-Digest 5) : Le mot de passe ne circule pas sur le réseau.

(Article sur le MD5 à venir)

 

 

 

Authentication Plain-text



Important :

  • le mot de passe doit être identique (max 8 caractères)
  • OSPFv3 ne supporte plus cette méthode

 

Étape 1 : Créer le mot de passe.

R1(config)# interface FastEthernet 0/0
R1(config-if)# ip ospf authentication-key [PASSWORD]

 

Étape 2 : Choisir où l’appliquer.

Pour ce faire deux méthodes :

-> Pour toutes les interfaces du routeur appartenant à l’aire OSPF :

R1(config)# router ospf 1
R1(config-router)# area [Num.d'AREA] authentication

-> Pour l’interface concernée :

R1(config)# interface FastEthernet0/0
R1(config-if)# ip ospf authentication

 

 

Configuration


 

Architecture de base
Architecture de base

 

Configuration de R1

R1(config)# interface FastEthernet0/0
R1(config-if)# ip address 10.10.10.1 255.255.255.0
R1(config-if)# ip ospf authentication
R1(config-if)# ip ospf authentication-key FINGER

R1(config)# router ospf 1
R1(config-router)# network 10.10.10.0 0.0.0.255 area 0

 

Configuration de R2

R2(config)# interface FastEthernet0/0
R2(config-if)# ip address 10.10.10.2 255.255.255.0
R2(config-if)# ip ospf authentication-key FINGER

R2(config)# router ospf 1
R2(config-router)# network 10.10.10.0 0.0.0.255 area 0
R2(config-router)# area 0 authentication

– R1 applique l’authentification plain-text sur son interface FastEthernet0/0
– R2 applique l’authentification plain-text sur les interfaces connectées à l’aire 0

 

 

Authentification MD5



Important :

  • Le mot de passe doit être identique
  • Le numéro de clef doit être identique

 

Étape 1 : Créer le mot de passe.

R1(config)# interface FastEthernet 0/0
R1(config-if)# ip ospf message-digest-key [KEY] md5 [PASSWORD]

 

Étape 2 : Choisir où l’appliquer.

Pour ce faire deux méthodes :

->  Pour toutes les interfaces du routeur appartenant à l’aire OSPF :

R1(config)# router ospf 1
R2(config-router)# area [Num.d'AREA] authentication message-digest

-> Pour l’interface concernée :

R1(config)# interface FastEthernet0/0
R1(config-if)# ip ospf authentication message-digest

 

Configuration


Architecture de base
Architecture de base

 

Configuration de R1

R1(config)# interface FastEthernet0/0
R1(config-if)# ip address 10.10.10.1 255.255.255.0
R1(config-if)# ip ospf message-digest-key 1 md5 FINGER
R1(config-if)# ip ospf authentication message-digest

R1(config)#router ospf 1
R1(config-router)# network 10.10.10.0 0.0.0.255 area 0

 

Configuration de R2

R2(config)# interface FastEthernet0/0
R2(config-if)# ip address 10.10.10.2 255.255.255.0
R2(config-if)# ip ospf message-digest-key 1 md5 FINGER

R2(config)# router ospf 1
R2(config-router)# network 10.10.10.0 0.0.0.255 area 0
R2(config-router)# area 0 authentication message-digest

– R1 applique l’authentification md5 sur son interface FastEthernet0/0
– R2 applique l’authentification md5 sur les interfaces connectées à l’aire 0

 

 

Authentification pour OSPFv3


[A VENIR]

 

 

 

CONCLUSION


 

 -> Privilégiez le MD5 au Plain-text.

Pour allez plus loin :

https://www.cisco.com/c/fr_ca/support/docs/ip/open-shortest-path-first-ospf/13697-25.pdf

 

 

En espérant avoir pu vous aidez !

N’hésitez pas si vous avez des questions ou si vous avez des informations à apporter.

 

FingerInTheNet

Noël NICOLAS

Expert Réseau
11 ans d’expérience
CCNP Routing and Switching
Fondateur du site FingerInTheNet

Created by potrace 1.10, written by Peter Selinger 2001-2011

Débloque l'intégralité des cours !

Abonnement